Resolved - LMS-326 Amendment list (LoDA or official list) is inaccessible
Issue
An amendment list can become inaccessible and can’t be opened in the Editor. This may affect a list of draft amendments (on the Amendment Workspace Tab) or an official list (on the Official Lists tab).
If a list is affected by this issue, when you click the Edit button for the list on the relevant tab, a new tab is opened and the progress bar begins but an error appears behind it instead of the Editor loading.
You may also see a “Failed to fetch” error pop up on the Amendment Workspace Tab or the Official Lists Tab:
Cause
The issue is being caused by data corruption in an index used by Lawmaker to assemble all the amendments within the list. It does not mean there is a problem with the amendments or the other content of the list but it prevents Lawmaker from making the compiled list available in the Editor.
We’re currently working on a fix that will avoid this being an issue in future.
Workaround
There are only limited workarounds to this issue because intervention from Leidos is required to properly fix the document in question.
We therefore recommend you take one of the following approaches:
If the affected list is a list of draft amendments (LoDA) then you can recreate the list by
On the Amendment Manager Tab, select the amendments that were in the LoDA.
In the Actions menu, select Create temporary list.
Once the list has opened in the Editor, in the toolbar select Document>Save as… to create a new LoDA.
If the affected list is an official list that doesn’t contain much content other than the amendments themselves (e.g. a Scottish daily list or a Lords daily sheet) then generating a new list may the easiest way to resolve the issue.
If the affected list is an official list that does contain more non-amendment content (e.g. a Commons Marshalled list) then duplicating an older version of the list and updating it may be possible if there haven’t been many changes made.
If you can wait for a resolution until the next working day, log a support request and we’ll get the list fixed overnight by Leidos.
If the matter is urgent and none of the approaches above will work for you, then request support directly from Leidos by using the phone number we have supplied. Their out-of-hours team should be able to fix the document in question fairly quickly.
Even if you work around the issue by taking an approach above, it would still be helpful if, at some point after, you can log a support request notifying us of the document that was affected so we are aware the issue has occurred and can investigate.